今天用 portupgrade 更新了 apache 之後,
就赫然發現 php 網頁開不起來...

原本以為是 apache 重裝完之後 php4 沒有跟著重裝所以爛掉了,
於是就手動重 compile 一次 php4 ,
結果還是不行,仔細一看 httpd.conf 裡面發現 php4 的 apache module 那一行被 comment 掉,
而 libexec/apache/ 下面的 php4 module 檔消失了...



啥?!
消失了?!

害我頓時以為我做錯什麼事情,
比如說升級到某個不能升級的版本之類...

後來東估西估,在谷歌上找了半天才找到解答:

「 php4 的幾個主要 ports entries 現在已經 merge 成 lang/php4 一支,
 預設 configuration 『不會』安裝 apache module ,需要的話要手動安裝」

所以就用 #make config 的指令把 build apache module 勾起來再重編一次就好了...



按,害我緊張死了

origin2 發表在 痞客邦 PIXNET 留言(0) 人氣()